Can't withdraw my UST from Anchor Protocol

Does anyone know why I can’t withdraw my UST from Anchor Protocol today? When I click withdraw it gives me a “waiting for Terra Station” message, then 5 min. later it gives me a “time out” message. Is anyone else having this problem? If so, do you know how to resolve it?

Where you able to resolve this?

Try to disable any adblockers or different browser? Reinstall wallet? I’ve successfully withdrawn my UST three days ago.

Had the same problem, just disconnected my Terra wallet from Anchor and reconnected it - worked perfectly straight after.

I am experiencing the same issue. I am a new anchor user and deposited some UST on anchor protocol through my terra wallet. I lent the UST to anchor through the “Earn” mechanism. But now I cannot withdraw the UST and get a message “Not enough transaction fees”. I have about 70 UST deposited so not sure why I am facing this issue. Can anyone advise ? Thanks

I believe you have to have at least .25 UST in your wallet to start a transaction. I too thought it would use the UST I was trying to withdraw for the transaction fees, but nope.

1 Like

I have the same prob, i made a deposit and i can’t withdraw anymore. Error ‘not enough ust to withdraw’ repeating. If i like to withdraw 800ust, 500ust on fees isnt enough. What is going on? I have send two emails but no reply


Is your problem solved? I’m having the same issue here.


Is this still happening? Can you open a discord ticket? Anchor Protocol

Is this still happening? Can you open a discord ticket? Anchor Protocol

Everything ok, thank you!

Thanks for the response ! It worked :slight_smile:

1 Like

That is just poor, counter-intuitive design. Hopefully it gets fixed in Anchor v2 and “fees” can be logically auto-deducted from the amount being withdrawn.

Everyone reasonably expects any fees to be deducted from the withdrawal (or there to be no fees; Terra sure charges a lot more fees than any bank on the planet, it seems like - but of course that is what generates the high yield and the LUNA staking returns).

1 Like

Has anyone tried to withdraw UST from anchor EARN today? Cant do it. Failed to broadcast transaction. Invalid hex string. Any ideas?

1 Like

Yes I did it 3 hours ago